Bug #798

Problem With Jails and Unable to Find Template on FreeNAS

Added by Daniel Curtis almost 2 years ago. Updated almost 2 years ago.

File Server
Target version:
Start date:
Due date:
% Done:


Estimated time:
0.50 h
Spent time:


I recently updated one of my FreeNAS 9.3 servers to 9.10 and for some reason I was unable to use FreeBSD 10.3 as the standard jail.

After looking online I found that someone had deleted the .warden-template-standard dataset to get their jail working again, so I went to the Storage section of the FreeNAS web interface and deleted the .warden-template-standard dataset.

  • Once the .warden-template-standard was deleted, I tried to recreate a standard jail, but the creation failed with the error message:
    Unable to find template
  • I then went to the Shell and tried to recreate the standard jail:
    warden template create -nick standard -tar
  • Creating the jail failed because apparently warden still thinks the standard template still exists. I then tried to delete the standard template with warden:
    warden template delete standard
  • Unfortunately the template couldn't be deleted because warden was looking for the .warden-template-standard dataset, and that had been deleted earlier.

The Fix

  • As it turns out, the utility that FreeNAS uses to manage jails also manages the ZFS datasets for the jails as well.
  • In order to fix the problem I needed to recreate the .warden-template-standard:
    zfs create zpool/jails/.warden-template-standard
  • Then use warden to delete the standard template
    warden template delete standard
  • Then recreate the standard template:
    warden template create -nick standard -tar



#1 Updated by Daniel Curtis almost 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#2 Updated by Daniel Curtis almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF