Bug #533

Problem Installing pfSense Failed With a Return Code of 1

Added by Daniel Curtis over 5 years ago. Updated over 5 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
1.00 h
Spent time:


I recently decided to install pfSense on an old i386 machine. The setup used the installer disc to install on a 40GB hard drive.

I began the installer by:
  1. Boot from pfSense Live Install Disc
  2. When prompted I pressed I to start the installer
  3. When the installer menu came up I chose Quick and Easy Setup

The problem I came across happened during the install process with the following error:

Execution of the command
/sbin/fdisk -v -f /tmp/new.fdisk ad0
FAILED with a return code of 1.

Resizing the partition to 30GB

I found that the current pfSense 2.1.5 installer fails to install on partitions larger than 30GB. To work around the error, I rebooted the pfSense installer disc and instead of booting the installer setup, I allowed the allowed it to boot until the prompt for configuring VLANs, I just chose N for this, because I just needed access to the shell.

  1. When the numbered prompt appeared, I pressed
  2. When the shell appeared, I ran the following:
    gpart show ad0
  3. This will display the hard drive and partitions, next I resized the partition to 30GB:
    gpart -i 1 -s 30GB ad0
  4. I then exited the shell:
  5. Then reran the installer:
  6. Next I chose a Custom Install
  7. I skipped the formatting step
  8. I also skipped the partitioning step
  9. I chose Accept and create bootblocks
  10. The same error came up while installing again, however I skipped the error
  11. I then chose Accept and create subpartitions
  12. And then selected the Symmetric Multi Processing kernel
  13. And finally I rebooted

This workaround managed to solve this problem for me.


#1 Updated by Daniel Curtis over 5 years ago

  • Description updated (diff)
  • Status changed from New to In Progress
  • Estimated time set to 1.00

#2 Updated by Daniel Curtis over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

#3 Updated by Daniel Curtis over 5 years ago

  • Status changed from Resolved to Closed

#4 Updated by Daniel Curtis over 5 years ago

  • Target version set to pfSense 2.1.5

#5 Updated by Daniel Curtis over 5 years ago

  • Category set to Firewall/Router

Also available in: Atom PDF